use TW2835 in freescale i.mx6q problem

Xinyu Guo's picture
Xinyu Guo asked on September 22, 2016 - 4:23am | Replies (1).

Hello.

I'm using TW2835 in freescale i.mx6q board now, and i get a problem.

I wired TW2835 camera to the CSI0 interface of the i.MX 6Quad

After I ran the camera application,it displayed black screen and got some error like below:

   case VIDIOC_DQBUF
In MVC:mxc_v4l_dqueue
ERROR: v4l2 capture: mxc_v4l_dqueue timeout enc_counter 0
The I2C communication is ok, and the registers value like below (i don't connect camera):

[email protected] /opt$ ./i2cshow 0
        0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00: 00 88 20 d0 05 20 28 80 80 80 80 82 06 00 11 00
10: 00 88 20 d0 05 20 28 80 80 80 80 82 46 00 11 00
20: 00 88 20 d0 05 20 28 80 80 80 80 82 86 00 11 00
30: 00 88 20 d0 05 20 28 80 80 80 80 82 c6 00 11 00
40: 00 77 07 45 a0 d0 2f 64 80 80 82 82 00 0f 05 00
50: 00 80 06 00 40 ff 00 00 00 00 00 00 00 00 00 00
60: 88 88 00 00 10 32 54 76 98 ba dc fe 00 00 88 88
70: 88 54 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80: 01 7f ff 7f ff 01 7f ff 7f ff 31 00 d0 00 20 28
90: 41 7f ff 7f ff 01 7f ff 7f ff 71 00 d0 00 20 28
a0: 81 7f ff 7f ff 01 7f ff 7f ff b1 00 d0 00 20 28
b0: c1 7f ff 7f ff 01 7f ff 7f ff f1 00 d0 00 20 28
c0: 00 00 00 0f 00 00 f0 ff 00 3c 4f 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 28 00
[email protected] /opt$ ./i2cshow 1
        0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00: 80 00 00 00 0f 84 00 00 00 00 20 d7 00 00 00 a3
10: 80 02 00 00 00 00 00 00 81 02 00 01 02 00 00 00
20: 82 02 00 02 00 00 00 00 83 02 00 03 02 00 00 00
30: 00 5a 00 48 5a b4 00 48 00 5a 48 90 5a b4 48 90
40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
50: 28 00 00 00 0f 80 40 03 00 00 00 00 00 00 20 a7
60: 80 00 00 81 02 00 82 02 00 83 00 00 ff e4 00 00
70: 00 03 00 01 23 00 00 00 0f 00 0f 0f f0 00 88 04
80: ff 00 51 07 eb 10 a8 00 40 c7 80 00 c0 c0 c0 c0
90: 00 00 00 00 00 00 00 00 ff ff 00 00 00 00 00 00
a0: 66 32 97 01 d0 20 00 0c 60 4c aa 70 40 40 00 00
b0: 00 00 ea 00 ff 00 ff 0f 0f 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[email protected] /opt$ ./i2cshow 2
        0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00: 00 00 00 00 00 50 59 00 35 03 60 e1 00 94 0d 0f
10: f0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 b0 00 00 00 00 40 00 00 00 00 00 00 b0 00 00
30: 00 00 40 00 00 00 00 00 08 00 00 00 00 00 00 00
40: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 40 40 40 42 ff
60: 88 00 01 0a 00 0b fb 00 89 00 5b 0a 00 0b fb 00
70: 8a 00 01 0a 48 0b fb 00 8b 00 5b 0a 48 0b fb 00
80: 17 73 88 4a 07 24 00 00 00 00 00 00 00 00 00 00
90: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0f 00
a0: 17 73 88 4a 07 24 00 00 00 00 00 00 00 00 00 00
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0f 00
c0: 17 73 88 4a 07 24 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0f 00
e0: 17 73 88 4a 07 24 00 00 00 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0f 00

I used oscilloscope to detect the signals of hardware:
1)the CLKVDOX pin outputs 27M waveform
2)the HSYNC, VSYNC output always high
3) VDOX0~VDOX7 always high

I config registers almost like the Recommended Value in datasheet,.

Am i missing something? why the HSYNC, VSYNC, VDOX0~VDOX7 always being high?

 

 

1 Answer

Justin Rohrman's picture

Hi,

 

Unfortunately I am not at all familiar with the technology you are using here. I would suggest looking at a more technical forum, StackOverflow for example, or talking with local experts that can look deeper into the problem you are having.

 

Justin

StickyMinds is a TechWell community.

Through conferences, training, consulting, and online resources, TechWell helps you develop and deliver great software every day.