Dot net framework 4.0 to 4.5 upgrade issue